3rd Party SSL Generation Network Issue
Incident Report for The Church Co
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 02:35 UTC
Monitoring
A fix has been issued. We are monitoring the servers.
Posted Nov 14, 2023 - 02:17 UTC
Identified
A segment of our hosts are affected by an upstream networking issue which has resulted in downtime for our third party ssl provider. Some apps will likely fail to load consistently due to the networking issues. They are working to resolve this.
Posted Nov 14, 2023 - 02:13 UTC