Issue with 3rd Party Infrastructure

Incident Report for The Church Co

Resolved

We're back online. We're monitoring the ongoing issues with aws but we are no longer affected at this time.
Posted Oct 20, 2025 - 08:59 UTC

Monitoring

We are continuing to monitor the status of our third party provider (https://health.aws.amazon.com/health/status).
Posted Oct 20, 2025 - 08:32 UTC

Investigating

We are closely monitoring the ongoing issue that has caused multiple services around the world to go offline. We will update her as we learn morning. When their issue is fixed we will also be fixed. Thank you for your patience.
Posted Oct 20, 2025 - 08:23 UTC